Quickstart

Requirements

To run correctly, ActiveLogic Python API requires Python 3.7 or later. You can run the following to ensure that you’re fulfilling this requirement:

>>> python3 --version
Python 3.8.0

Download and install

Download the latest version of ActiveLogic Python API from Sandvine Software Library. The API is compatible with ActiveLogic systems that are running 20.30 and later. The recommendation is to always use the latest stable version of the Python API.

Install the API using pip:

$ pip3 install activelogic-23.21.00.6-py3-none-linux_x86_64.whl

Connect to a system

Connecting to a system is as easy as:

>>> import activelogic as pl
>>> pl.sync_connect("192.168.1.25", "admin", "password")
>>> sd = pl.sysdiag()